haxecpp compile error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

haxecpp compile error

tom rhodes
Hi all,

i've gone through all the install instructions found here...


...but, i get this error when compiling...

LINK; fatal error LNK1104: cannot open file 'user32.lib'
Called from ? line 1
etc.

a few things were different in my set up, windows 7 ultimate 64bit (italian), visual basic express 10 and not 9 too so i've had to adapt the environment variabels a little to suit. it gets almost to the end it seems as it sppears to have created the directory structure and a lot of files including a c source file. before adjusting some stuff i was getting cl errors....

anyone know how i can fix it?

thanks,

tom.

--
haXe - an open source web programming language
http://haxe.org
Reply | Threaded
Open this post in threaded view
|

Re: haxecpp compile error

Gamehaxe
Hi,
This indicates that the $LIB variable is not set up correctly.
If may also be that you need to install a "windows sdk" add on.

You can try the new experimental feature in the svn hxcpp build,
by defining the variable "msvc10", which then attempts to set the
variables up for you, eg:

haxe -main ...... -D msvc10

If is possible that the italian version also uses slightly different
variable names, and something might need to be adjusted slightly.
If you can post more of the build output then I might be able to
give some more specific answers.

Hugh

> Hi all,
>
> i've gone through all the install instructions found here...
>
> http://blog.touchmypixel.com/2009/04/our-possible-haxe-c-plans/
>
> ...but, i get this error when compiling...
>
> LINK; fatal error LNK1104: cannot open file 'user32.lib'
> Called from ? line 1
> etc.
>
> a few things were different in my set up, windows 7 ultimate 64bit
> (italian), visual basic express 10 and not 9 too so i've had to adapt the
> environment variabels a little to suit. it gets almost to the end it  
> seems
> as it sppears to have created the directory structure and a lot of files
> including a c source file. before adjusting some stuff i was getting cl
> errors....
>
> anyone know how i can fix it?
>
> thanks,
>
> tom.

--
haXe - an open source web programming language
http://haxe.org