errors Linux copyPixels() and win7 addChild()

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

errors Linux copyPixels() and win7 addChild()

watsnow
hi guys!
when i run my app using copypixels() on Linux it crash. And segment error output in terminal.

On my win7,when i add two bitmap(bitmapData using BitmapData.load()) on stage using addChild(), it can not show correctly. the nme sample 06-Sound has the same problem.Seem the bitmapData has the same reference.
Reply | Threaded
Open this post in threaded view
|

Re: errors Linux copyPixels() and win7 addChild()

Gamehaxe
Hi,
Try compiling with the "-debug" flag - this should give you some better  
error checking.
On linux, you can then run your exe using gdb, eg:  "gdb cpp/Sample.exe"  
and then
type "run" in the console.  If you get a crash, you can type "where" to  
get some
helpful info about where it goes wrong.

Something looks seriously wrong on your win7!  I wonder if it is to
do with the opengl drivers?  What graphics card do you have, and have you  
set
Lib.HARDWARE ?

Hugh

>
> hi guys!
> when i run my app using copypixels() on Linux it crash. And segment error
> output in terminal.
>
> On my win7,when i add two bitmap(bitmapData using BitmapData.load()) on
> stage using addChild(), it can not show correctly. the nme sample  
> 06-Sound
> has the same problem.Seem the bitmapData has the same reference.
> http://haxe.1354130.n2.nabble.com/file/n5501800/QQ%E6%88%AA%E5%9B%BE%E6%9C%AA%E5%91%BD%E5%90%8D2.png

--
haXe - an open source web programming language
http://haxe.org
Reply | Threaded
Open this post in threaded view
|

Re: errors Linux copyPixels() and win7 addChild()

slenkar
In reply to this post by watsnow
you may have to produce a little demo for each bug, with source
Reply | Threaded
Open this post in threaded view
|

Re: errors Linux copyPixels() and win7 addChild()

watsnow
In reply to this post by Gamehaxe
i try it with the "-debug" flag,but get no error.
Reply | Threaded
Open this post in threaded view
|

Re: errors Linux copyPixels() and win7 addChild()

watsnow
In reply to this post by slenkar
nme sample 06-Sound
Reply | Threaded
Open this post in threaded view
|

Re: errors Linux copyPixels() and win7 addChild()

watsnow
In reply to this post by Gamehaxe
It is Ok when i change 1*Lib.HARDWARE to 0*Lib.HARDWARE.
copyPixels on linux i will try later.
Thanks a lot.