You can't access the flash package with current compilation flags

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

You can't access the flash package with current compilation flags

justin_mills
When running a project with new 2.07 build I noticed I had to change
haxe -swf-lib bin/swf/GUI.swf --gen-hx-classes

It seems to be complaining now though?

..."You can't access the flash package with current compilation flags
(for flash.display.MovieClip)".

Any suggestions?

--
haXe - an open source web programming language
http://haxe.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: You can't access the flash package with current compilation flags

Simon Krajewski
  Try specifying a dummy output -swf dummy.swf so the compiler knows
what your compilation target is. -swf-lib does not seem to imply flash
target.

Simon

Am 04.02.2011 16:22, schrieb justin_mills:

> When running a project with new 2.07 build I noticed I had to change
> haxe -swf-lib bin/swf/GUI.swf --gen-hx-classes
>
> It seems to be complaining now though?
>
> ..."You can't access the flash package with current compilation flags
> (for flash.display.MovieClip)".
>
> Any suggestions?
>

--
haXe - an open source web programming language
http://haxe.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: You can't access the flash package with current compilation flags

Maboroshi94
This post has NOT been accepted by the mailing list yet.
I dont understand, please can you explain how it is done?
Loading...